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Objectives

At the end of this training session you should be able to:

1. Understand the three types of relationships: one-to-many, many-to-many                 
 and one-to-one;

2. Create a new database;

3. Create tables for data entry in design view;

4. Use, understand, and set data types: Text, Memo, Number, Currency,                                      
    Date/Time, AutoNumber, Yes/No, Lookup wizard.

5. Create and delete a primary key;

6. Insert and delete a row.
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Before a database is developed, plan the structure from the beginning to the end.  Flow-
charting or blueprinting in advance will eliminate restructuring and/or starting from 
scratch.

Questions to Ask Before Designing a Database:

1.  What does the database need to do?
2.  What functions need to be achieved?
3.  Which objects (such as tables, forms) depend on each other?
4.  What items are needed for the database?
5.  Who will use the database?
6.  How will the output data (report) be generated?
7.  How will the database be organized?

Access Database Terminology

It is necessary to understand and be familiar with the basics of a database and its ob-
jects to create or generate information.

Table- The central framework of a database that stores data in fi elds (columns) and re-
cords (rows).

Query-  Allows for table inquiries.  A query can change, delete, add, arrange data in 
tables.  Also aids gathering information for forms and reports.

Form-  Displays and enters data in a fi tted format.  Forms can also contain other nested 
forms (subforms).

Report-  Allows for the printing and print preview of information such as labels, lists, 
form letters, invoices, summaries, display charts, etc. The user can personalize reports 
by adding a logo or picture, organizing headers, details, footers, and sorting columns.

Page-  Also known as Data Access Page.  Allows the publication of a web page and web 
access to a database.  A page can be viewed and edited, and the information can be 
altered.

Macro-  Allows for automating simple and common tasks such as opening and closing a 
form, exporting data, printing data in a report, and saving data.

Module-  Modules are a collection of Visual Basic declarations and procedures that al-
low for the automation and customization of Access, giving the user more explicit control 
over actions.  
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Naming Conventions  

The Leszynski Naming Convention (LNC), originally created by Stan Leszynski and Greg 
Reddick, developed guidelines called tags to assist the user to open, edit, and trouble-
shoot without deciphering what is contained within the object itself. 

File names can be more than one word; however, do not use underscores or spaces.  In-
stead, capitalize the fi rst letter of each word.
   e.g. tblEmpInfo

Recommended Naming Conventions

     Table    tbl
     Query   qry
     Form    frm
     Report    rpt
     Macro   mcr
     Module   mdl
     Database   dbf
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When organizing and creating a data-
base, the question, "How will the ob-
jects  (tables) relate?" must be asked.

There are three types of relationships in 
Microsoft Access:
     One-to-many
     Many-to-many
     One-to-one

One-to-many relationship 
The most common type of relationship.  A 
record from one table (Table 1) can have 
matching records in another table (Table 
2); however, Table 2 has only one match-
ing record in Table 1.  

Let's look at the example. 
1 One Department

2   has more than one Course,

3   yet each Course has one Department.

 
Many-to-many relationship
Not recommended due to problems en-
forcing referential integrity.  A record from 
one table (Table 1) can have many match-
ing records in another table (Table 2) Also, 
a record in Table 2 can have many match-
ing records in Table 1.  This is possible 
through the use of a third table called a 
junction table.  The junction table has a 
primary key that consists of two fi elds 
from Tables 1 and  2.  

Let's look at the example. 
1 Primary key from Inventory Details table 

(tblInventDetails)

 2 Primary key from the equipment table 
(tblEquipment)

3 One department can have several types of 
equipment,

4 And each type of equipment can appear in 
several departments.

1

Table 1

3

2

Table 2

3

1

4

Table 1

Table 2

Junction Table

2
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One-to-one relationship
 
Least common type of relationship.  How-
ever, a one-to-one relationship is useful if 
there are records that must be kept confi -
dential and secure.  A record from one table 
(Table 1) can have one single matching 
record in another table (Table 2), and Table 
2 can have only one single matching record 
in Table 1.  

Let's look at the example. 

1 All students’ have one matching record in 
students table (tblStudents)

2  The values are a subset of the social security 
fi eld and the students’ table (tblStudents).   

1

2
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Create a New Database

Before creating tables and forms, creating a 
general database is recommended.

1. Under the Getting Started task pane, click on 
Create a new fi le link. 

2. Click on Blank Database from the menu bar.

3. After the Fill New Database appears, type the 
fi le name of the database.

 e.g. HCC_Employee_Data

4. Click Create or press Enter on your keyboard. 1

2

3 4
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Create a Table Using Design 
View

Creating a table in Design View gives the 
user freedom to construct a table with 
specifi cations for data collection.

1. Under Objects, click on Tables.

2. Click on Create table in Design view.

3.  Type in the Field Name.
e.g. LastName

When entering fi eld names, do not use 
spaces or punctuation.

4. Under Data Type, click on the down arrow and 
select Text.

 Look at page 9 for Data Type descriptions or 
hit F1 on your keyboard for more details and 
help on data types.

5. Locate the General tab and type 20 for the 
Field Size.

 Typing in 20 for the fi eld size indicates that the 
last name can be no more than 20 characters 
long.

6. Type a label for the Caption.
e.g. Last Name:

Spaces and punctuation can be used for 
captions. Whatever is typed in the caption 
will appear in both forms and reports. If 
no caption is entered, the fi eld name will 
appear instead.

Add the following fi elds to the table, FirstName, 
MI (middle initial), Street, City, State, Zip, Exempt 
(Yes/No) and Campus (Lookup Wizard). Also add the 
Field Size and Caption for each fi eld name. 

Activity
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Save a Table

Saving a table with a specifi c title will help 
when organizing information, creating 
queries, forms, and pages, and connecting 
to other tables.

In this example, we are saving the table, 
tblEmployeeInfo.

1. Click on File>Save As. A Save As dialog box 
appears.

2. Type the name of the table.
e.g. tblEmployeeInfo

3. Click on OK.

4. A dialog box appears stating that no primary key 
is defi ned. In this example, select No.

Primary keys are not required; however, 
select a primary key when you need 
to create relationships between tables 
in a database. Primary keys cannot be 
duplicated; therefore, never use a last 
name, address, or a fi eld where information 
is likely to be repeated. Ideal primary keys 
are employee numbers, social security 
numbers, product numbers, etc.

1

2 3

4
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Data Types

It is important to assign data types to a fi eld since they specifi es what type of 
data can be entered into a fi eld.  

Data Type     Description
Text Add text entries and number entries that do not 

require calculations such as addresses, social secu-
rity numbers, dates, and phone numbers.  Maximum 
number of characters, including spaces, is 255 char-
acters.

Memo Add long text or number entries.  Maximum number 
of characters is 64,000.  Use when more than 255 
characters are necessary.

Number Add positive/negative numbers for calculations. Not 
appropriate for currency or items that require exact 
calculations.  15 digit maximum.

Currency Use for calculations that do not need to be rounded.  
15 digit maximum.

Date/Time Add date and time. 8 character default.

AutoNumber Use when sequential, random, or replication ID num-
bers are needed.  9 digit maximum.

Yes/No Use when Yes/No, True/False, or On/Off are neces-
sary.

OLE Object Add objects such as Excel workbooks or Word docu-
ments that are linked or embedded.  1 gigabyte 
character limit.

Hyperlink Link to fi les, objects, or web links.  2,048 character 
maximum.

Lookup Wizard Use when choosing data such as tables or a list of 
values.    
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Insert Input Mask Wizard

The Input Mask Wizard allows the designer 
to defi ne the format for entering data.

In this example, a format is set for entering 
a zip code.

To use the input mask wizard the table must 
be in Design View.

1. Type Zip under the Field Name.

2. Select Text for Data Type.

3. Type Zip: for the Caption.

4. Click in the Input Mask fi eld.

5. Click on the  build button.

 An Input Mask Wizard box appears. In this 
example, the Zip Code format is selected.

6. Select Zip Code.

7. Select a placeholder and click on Next.

 The underscore _ is the default placeholder 
character. 

8. Click on Next. 

1

6

7

3 5

2

4

8
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Create a Custom Input Mask

Creating a customized Input Mask ensures 
formatting for entering data. If the 
information is not entered appropriately, the 
data will not be accepted.

In this example, a zip code input mask is 
created.

To create a custom input mask, the table 
must be in design view.

1. Select the Field Name to create the Input 
Mask. In this example, use Zip.

2. Under Field Properties, click in the Input 
Mask fi eld.

 A build button appears to the right of the Input 
Mask fi eld.

3.  Click on the  build button.

4.  After the Input Mask Wizard dialog box 
appears, click on Edit List.

5. Enter the Description, Input Mask, 
Placeholder, Sample Data, and select Text/
Unbound for Mask Type.

6. Afterwards, click on the Close button to save 
the Zip Code input mask.

1

32

4

5 6
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9. Click on the With the symbols in mask radio 
button.

 Here the data can be stored with symbols or 
without symbols in the table. Storing with 
symbols allows for easy viewing of the data. 

10. Click on Next.

11. Click on Finish.

 Notice that the Zip Code Input Mask is added 
under the Field Properties>Input Mask> 
0000-9999;;.

To see the formatting in the table, click on 

the  Datasheet View button.

9

10
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Data Type: Yes/No

As mentioned on page 9, data types are use 
to specify what type of data can be entered 
and stored into a fi eld.

In this example, the Yes/No data type is 
used for Exempt fi eld name. Using the Yes/
No format is helpful for simple, clear-cut 
answers.

To use the data type Yes/No the table must 
be in design view.

1.  Type in Field Name.
e.g. Exempt

2.  Under Data Type, click on the down arrow and 
select Yes/No.

 Yes is represented by a check and No is not 
checked in the Datasheet View.

Yes/No also represents the following: True/
False, 1/0, and On/Off.

1

2
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Data Type: Lookup Wizard

The purpose of the Lookup Wizard is to 
connect one fi eld from one table to another 
table or a list of values. Using the Lookup 
Wizard is useful when choices need to be 
limited or the same. 

For instance, Hillsborough Community 
College has the campus location of District 
Adminstrative Offi ces. If members of the 
HCC community were to type District 
Adminstrative Offi ces in a table, they 
could type GK, DAO, District Adminstrative 
Offi ces, or some other spelling or mispelling. 
Therefore, restricting the location to DAO 
ensures the same information is entered.

In this example, a drop-down menu is 
created by using the Lookup Wizard, 
which will connect to tblCampus. 

To use the Lookup Wizard the table must be 
in design view.

1. Type in the Field Name.
e.g. Campus

2. Under Data Type, click on the down arrow and 
select Lookup Wizard.

3. A Lookup Wizard dialog box appears. Click on 
the I want the lookup column radio button.

4. Click on Next.

5. Select the table for the lookup.
e.g. Table:tblCampus

6. Click on Next.

1

2

3

4

5

6
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7. Select the available fi eld to include by clicking 
on the single-headed next arrow.
e.g. Campus

8. Click on Next.

9. Set sort order as needed and click on Next.

10. Adjust the width of column and click on Next.

11. After entering the label name for the lookup 
column, click on Finish.
e.g. Campus

12. Click Yes to save table and create relationships.

To view the down-drop menu for the 
different campuses, click on the  
Datasheet View button.

To manually add a drop down menu, click 
on the Lookup tab under Field Properties. 
Next set the Display Control to Combo 
Box and the Row Source to the required 
table or query. In this example, use 
tblCampus.

7

8

12

Use the Lookup Wizard to connect the fi eld name 
State to the table tblState. 

Or challenge yourself and manually add a lookup.

Activity
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Insert Field to a Table in 
Datasheet View

After a table is created, additional Field 
Names may be needed.

In this example, we are adding an 
EmployeeID (employee number) fi eld.

To insert the fi eld the table must be in 
design view.

1. Click on the row below where the fi eld is to 
appear.

 In this example, click on the fi eld name 
LastName.

2. Click on Insert>Insert Row or the  Insert 
Row on the toolbar.

3. Type in Field Name and Data Type

 e.g. Field Name: EmployeeID 
       Data Type:   Text

 Remember to enter the Field Properties details 
under the General Tab. Field Size: 7 and 
Caption: Employee ID:.

 The data type is set to Text because this data 
doesn’t require any calculation.

To delete a Field Name, select the Field 
Name row selector (small boxes located 
to the left of Field Names) and press the 

Delete key or the  Delete Row on the 

toolbar or Edit>Delete or Delete.

1

2

3

Insert a Field Name named AutoNum with a Data 
Type of AutoNumber. Enter the Caption as Entry 
Number:.

Activity
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Set a Primary Key

A primary key or primary keys uniquely 
identify each record in a table. An 
advantage of a primary key is that it does 
not allow duplication of information. Access 
does not require that a primary key, and 
multiple primary keys can be set.

In this example, a primary key is set for 
the Field Name: EmployeeID. 

To set a primary key, the table must be in 
design view.

1. Click on the row selector for the fi eld to be set 
as a primary key.
e.g. EmployeeID.

2. Click on the Primary Key button.

 If the there is more than one primary key, press 
and hold down the Ctrl key, and click on the 
row selector for other fi elds.

To remove a primary key, click on the row 
selector of the fi eld set as a primary key 
and click on the primary key button.

1
2

Set a primary key for AutoNum and remove the 
primary key for Employee ID.

Activity


