Microsoft Excel 2007: Module 3

August 2007
# Table of Contents

Objectives ................................................................. 1  
PivotTable ................................................................. 3  
  Purpose ................................................................. 3  
  Create a PivotTable .................................................. 3  
  PivotTable Layout Area ............................................. 4  
  PivotTable Tools Options Tab ..................................... 5  
  Populate PivotTable with Data .................................... 6  
  Change Summary Calculation ...................................... 6  
Add Data and Pivot a PivotTable .................................... 8  
Rename Data Headings .................................................. 9  
Remove Data from PivotTable ....................................... 9  
Report Filter ............................................................. 9  
Group and View Underlying Data ................................... 10  
Create a Chart ........................................................... 12  
Format a Report .......................................................... 13  
Macros .......................................................... 14  
  Purpose ............................................................... 14  
  Security Setting ...................................................... 14  
  Record and Run a Macro ............................................. 15  
  Create a Macro Shortcut ............................................ 16  
  Record a Macro to Alter Format .................................. 17  
  View Macro in the VB Script Editor .............................. 18
Objectives

At the end of this training session you should be able to:

1. Understand the purpose of a PivotTable;
2. Choose the correct data source for the PivotTable;
3. Choose the information desired on the PivotTable;
4. Alter Pivot Table layout;
5. Group and view data within a PivotTable;
6. Create a chart from a PivotTable;
7. Format a report from a PivotTable;
8. Understand the purpose of a macro;
9. Plan out a macro;
10. Record a macro;
11. Run a macro;
12. Assign a macro to a button.
PivotTable

What does a PivotTable do?

A PivotTable is an interactive table that summarizes large amounts of information and can be manipulated to show the data from different perspectives.

Create a PivotTable

1. Open an Excel file.
   e.g. Excel2007_M3.xlsm
2. Click within the data range that the PivotTable will use.
   e.g. cell A1, in the Data worksheet
3. On the Insert tab>Tables group, click on PivotTable.
4. The Create PivotTable dialog box appears. Check to see if the data source range is correct. If necessary, make the corrections in the Table/Range box.
5. Be sure New Worksheet is selected.
6. Click OK.
7. The **PivotTable layout area** is visible, along with the **PivotTable Field List** and the **PivotTable Tools** tab. Now you can manipulate the data.

A. **Row Labels** are what the data is grouped by. For example, grouped by campus.

B. **Column Labels** separate data into one column for each record.

C. **Report Filter** separates the data into subsets. For example, you can view each campus individually, or view any combination of the campuses.

D. **∑ Values** are the fields that are summarized in the PivotTable.
PivotTable Tools Options Tab

Once you have created a PivotTable, a new tab appears in the Ribbon. Click the **PivotTable Tools** tab to bring up the PivotTable options. The **PivotTable Options** tab has commands for grouping, sorting, adding/removing subtotals and formulas. Some popular options are:

1. **PivotChart** is used to choose a professional format for your report.

2. **Show/Hide** controls the visibility of the Field list, +/- buttons in the PivotTable and the Field headers.

3. **Refresh Data** updates the Pivot Table when data from the original source changes.

4. **Field Settings Dialog Box** brings up the **Pivot Table Field Dialog Box**. You can change the field’s number format or choose a different summary function (sum, count, average, etc.).

5. The **Options** dialog box is where you can set preferences for showing contextual tool tips, layout, format and for showing the classic PivotTable layout.
Populate the PivotTable with Data

1. To compare campus data, check the Campus box in the PivotTable Field List. It will automatically appear in the Row Labels area and in the PivotTable.

2. Drag and drop the data you would like to view into the $\sum$ Values box.  
   e.g. Salary

3. Now the PivotTable shows the total salary by campus.

Change Summary Calculation

1. The default summary calculation is Sum. To change the function, click on the field under $\sum$ Values and select Value Field Settings. 
   e.g. Sum of Salary
2. The Value Field Settings dialog box appears. Select Average.

3. Click on Number Format to reformat this column.

4. Click Currency and OK on the Format Cells dialog box.

5. Click OK on the Value Field Settings dialog box.

6. The PivotTable has been updated to show averages of salaries that are formatted as currency.

Activity

Create a pivot table from the Buccaneer attendance data on worksheet Activity1. View Attendance by Opponent. Which game had the highest attendance? Lowest?
Add Data and Pivot the Pivot Table

PivotTables are good at quickly displaying reorganized information. For example, to see if gender affects salaries, we can view the data by gender or we can pivot the table to view the data by campus.

1. Click Gender in the PivotTable Field list box.
2. Now you can see a summary of salaries at each campus, by gender.
3. To pivot the table to group salary by gender, then campus, click on the Campus bar in the Row Labels area.
4. Select Move Down from the drop-down list.
5. Now the campus salaries are grouped by gender.
Rename Data Fields in the PivotTable

1. As you manipulate your PivotTable, you may want to alter the field headings. To change a heading, click on the heading and type a new title.
   e.g. Change **Average of Salaries** to **Salary Average**.

Remove Data from the PivotTable

2. To remove any field from the PivotTable, deselect the field in the **PivotTable Field List**.
   e.g. **Campus**

3. Re-select **Campus** from the **PivotTable Field List** or click **Undo** to place the field back into the table.

Report Filter

To view one of your category groupings at a time, use the **Report Filter** feature.

4. To view campus data separately, click on **Campus** in the **Row Labels** area.
5. Select **Move to Report Filter**.
6. Now the data can be viewed by each campus separately or all together. Click on the **arrow** in B2 to select an individual campus.
   e.g. **YB-Ybor**

7. To view all data again, click and drag **Campus** back into the **Row Labels** area.
Group and View Underlying Data

1. Let’s see if there is a hiring pattern related to time of year. De-select Gender and select StartDate from the PivotTable Field List. Move StartDate to the top of the Row Labels area. This will change the grouping of the data from gender or campus to start date.

2. Each day a person was hired is listed down the left side. To group the dates by week, month or quarter, instead of day, click on a date.
   e.g. cell A5

3. In the PivotTable Tools/Options tab>Group group, select Group Field.

4. The Grouping dialog box appears. Select the appropriate group and click OK. If the dialog box does not automatically appear, right click on cell A5 and select Group.
   e.g. Quarters

If you would like to group by month, you should decide if it matters what year the month is in. For example, all January entries will be grouped together, even if they are in different years. If the year matters, then select Month and Year.
5. Change Salary Average to Count, so we can see how many people were hired at each campus, during each quarter. Click on the Salary Average under ∑ Values and select Value Field Settings from the drop-down list.

6. Choose Count.

7. Click Number Format and select General. Click OK.

8. Click OK.

9. Click +/- button next to the row label to show/hide the summary of the count for that quarter.

10. Double click on any of the cells to show/hide the underlying data.
   a. Row Labels data will appear in the PivotTable.
   b. ∑ Values details will appear in a new spreadsheet.
   c. Double click on Qtr1. What happened?
   d. Double click in the Count area. What happened?

**Activity**

Use the PivotTable from the data on worksheet Activity1. Add Date to the row fields area of the pivot table. Which month has the highest average attendance? Lowest?
Create a Chart

1. Select a cell within the PivotTable.
2. Select PivotChart from the PivotTable Tools/Option tab.
3. The Insert Chart dialog box appears. Select your chart and click OK.
4. Your chart and the PivotChart Filter Pane appear.
5. Edit the chart title. Double click on Total and type in Hiring by Quarter.
6. Use the buttons to the right of the Axis Fields in the PivotChart Filter Pane to adjust the amount of data displayed in the chart. Click on the Start Date button and deselect everything except Qtr1. Click OK.
7. Now the chart and table only show the data for Qtr 1.

Go to the Design tab to change the style of your chart.

Activity
Create a chart of the PivotTable data from worksheet Activity1.
Format the Report

When your PivotTable is showing the information the way you would like, you can select a report format. This will make your PivotTable look more professional. You can apply the cell styles or font from the Home tab, or you can use the PivotTable styles on the Design tab. To make sure your information will display properly in the report, you should wait to select the format until your table is just the way you want it.

Click back on the PivotTable worksheet.

1. Click the Design tab>PivotTable Styles group.
2. Select your format.
3. Use the arrows to the right of the styles to scroll through more options. Click the bottom arrow to see all the choices in one screen.
4. Other design options are row/column headings, subtotals/totals and the report layout.
5. Select or deselect options in the PivotTable Style Option group to alter the chosen PivotTable Style.
6. Use the Subtotals menu in the Layout group to show/hide subtotals or to select the location of the subtotals.
7. Use the Grand Totals menu in the Layout group to show/hide grand totals or to select the location of the subtotals.
8. Use the Report Layout menu in the Layout group to select the report form - compact, outline or tabular.

Activity

Create a report of the PivotTable data from worksheet Activity1.
Macros

The purpose of a macro is to automate repetitive tasks. Do you have a specific print style in the header or footer that you always use? Do you use the same series of keystrokes often? If so, then you can automate these tasks by using macros.

For macros to be able to run, you may need to adjust the security level. This is in the Developer tab, which may not be initially visible.

1. Go to the Microsoft Office Button.
2. Select Excel Options.
3. Select Show Developer tab in the Ribbon. Click OK.
5. Choose Disable all macros with notification. This option gives you the choice to run or cancel a macro. Click OK.
Record and Run a Macro

Creating a macro starts out with a purpose. What are you trying to accomplish? Set up your spreadsheet accordingly, then you can record the necessary keystrokes and your macro is ready to use.

1. Set up a simple grade calculator for students to use. This macro will erase scores and set the active box to B1. Select worksheet Macro1.

2. Type numeric grades in the yellow boxes.

3. From the Developer tab>Code group select Record Macro.

4. Name the macro GradeCalculator (no spaces). Type in g for the Shortcut Key. You have the option to save the macro in this workbook, another workbook or for all workbooks. Select This Workbook. Click OK.

5. Erase the grades in the yellow boxes and click back in cell B1.

6. Click the Stop button, in the Code group of the Developer tab, or in the bottom left corner of the screen.

7. Test the macro by typing in another list of grades. Then start the macro by typing the shortcut keys of Ctrl + g. The macro should erase the values and return to cell B1.

Activity

Use worksheet Activity2. Record a macro to erase the expenses and paycheck amount and return to cell B1. Re-enter expenses and run the macro to test it.
Create a Macro Shortcut

After a macro is created, you can assign it to the Quick Access Toolbar. If you are going to use the same macro repeatedly, it is convenient way to start the macro.

1. Click the down arrow that is to the right of the Quick Access Toolbar.
2. Select More Commands.
3. Select Customize from the left panel.
4. Click the down arrow to the right of Popular Commands and select Macros from the drop-down list.
5. The available macros are listed in the left panel. Choose GradeCalculator and click Add.
6. Click Modify to change the icon. Click OK.
7. Click OK.
8. Now the macro is available in the Quick Access Toolbar.

Activity

Create a macro shortcut button for the macro you recorded on worksheet Activity2.
Record a Macro to Alter Spreadsheet Format

The purpose of this macro is to set a format for one set of data and then use the macro to format other sets.

1. Click in cell A1, on the worksheet Macro2.
2. Go to Developer tab>Code group>Record Macro.
3. Name the macro Reorganize. Type in r for the Shortcut Key. Click OK.
4. Click Use Relative References, in the Code group.
5. Cut cell A2 and paste it into cell C1. Cut cell B2 and paste it into cell D1.
6. Click on cell A2.
7. Click on the Home tab>Cells group, select Delete Sheet Rows.
8. Click on the new cell A2.
9. Click on the Home tab>Cells group, select Delete Sheet Rows.
10. The cell pointer should be in cell A2. Click the Stop button.
11. Test the macro by typing the shortcut keys of Ctrl + r. The macro should update the format of the next set of data. Continue on and rerun the macro to reformat the remaining sets of data.
View Macro in the VB Script Editor

You can view, create or edit any macro in the VB Script Editor.

1. From the Developer tab>Code group, select Macros.
2. Select the macro you would like to view, such as GradeCalculator. Click Edit.
3. Now the VB Editor is open and you can view or edit the macro.
4. Click the Excel Icon, in the toolbar to go back to your worksheet.

Activity

Record a macro to highlight the Wins (W) in the data from Activity1.